Announcement New JustUo Test Shard up and running

Discussion in 'News and Announcements' started by zerodowned, Dec 21, 2015.

  1. zerodowned

    zerodowned Administrator Moderator JustUO Developer Gold Star Member Et Cetera, Et Cetera

    *Update: this thread is no longer a sticky. The test shard has been down for a while now and no plans to host again any time soon.
    All bug reports are being saved for later use.


    We're in process of testing the Enhanced Client support before adding it to the Repo.
    I'd like to ask everyone to try it out with the Enhanced Client, just play as your normally would, and report back any issues that you find.

    We now have an invitation up on ServUO as well and dmurphy has pinned it to their front page. :Smile:

    IP: 217.146.93.186
    Port: 2593

    Requirements to play:

    - Download and install the EC client if you don't already have it
    - Then download unzip and drop the UoSaLoader files ( found below ) into the EC client file
    - Login IP and Port is now included in the file download below
    - Then run the program "uo-ec-loader" and you should be able to create an account and play as normal

    Thank you
     

    Attached Files:

    Last edited: Mar 24, 2016
    • Winner Winner x 1
  2. Zycron

    Zycron Illustrious Member JustUO Developer

    Is EC support pushed to the public repo yet or you guys just beginning testing? i was really sick and had some surgeries to go through im back now though. you all have made great strides!!
     
  3. zerodowned

    zerodowned Administrator Moderator JustUO Developer Gold Star Member Et Cetera, Et Cetera

    It's not included in the official repo yet.

    I have a fork of the most recent JustUo that has been merged with EC Support, and that fork is what we're using to run the test shard: https://github.com/zerodowned/JustUO

    Ravenwolfe and I both agreed it was best to test it on a live shard first to help locate and fix any bugs that arise before pushing to the offical repo.
     
  4. Zycron

    Zycron Illustrious Member JustUO Developer

    Indeed it is better :) i was tagged as a dev when this project first started guess i got removed from inactivity due to my surgeries but im back now so if u guys need help in any areas or a dedicated server thats up 100% for the test servers just let me know ;P
     
    • Like Like x 1
  5. Zycron

    Zycron Illustrious Member JustUO Developer

    Cannot login i downloaded EC client patched up dropped in the file ran the launcher put my acc name and pass in it says unable to auth login
     
  6. zerodowned

    zerodowned Administrator Moderator JustUO Developer Gold Star Member Et Cetera, Et Cetera

    hmm, strange.
    you should be able to create an account without any problem.
    try creating an acct in classic client to see if that works
     
  7. Zycron

    Zycron Illustrious Member JustUO Developer

    regular client works fine. try to go back to EC says same thing again
     
  8. zerodowned

    zerodowned Administrator Moderator JustUO Developer Gold Star Member Et Cetera, Et Cetera

    okay, i'll have to look into it later.
     
  9. Zycron

    Zycron Illustrious Member JustUO Developer

    much appreciated Id like to start checking it out ;)
     
  10. Nagash

    Nagash PlayUO Prospect

    It seems the cheese.dll file is missing from the archive provided above. By installing this you should be able to pass the authentication. You can find the dll in this archive
     
    • Like Like x 1
  11. Nagash

    Nagash PlayUO Prospect

    Tested some basic features like combat and moving around. Have to say it looks pretty good. The only thing that bothered me very slightly was the feeling of having a floating character while running around. Not sure how to otherwise describe it.
     
  12. Zycron

    Zycron Illustrious Member JustUO Developer

    Figured my problem out. that loader doesnt work with the newest ver of the EC over at abc UO they have a loader for their server that let me in just fine ;P so i just gotta see if i cant edit it to get on JustUO's test server.
     
  13. zerodowned

    zerodowned Administrator Moderator JustUO Developer Gold Star Member Et Cetera, Et Cetera

    Thank you for reporting that, I'll update the loader

    ** the Loader has been updated **
     
  14. zerodowned

    zerodowned Administrator Moderator JustUO Developer Gold Star Member Et Cetera, Et Cetera

    I believe they have a custom patcher to make the client login to their shard.

    I'd suggest moving their client version to a different file or renaming it if it's in this location: Program Files\Electronic Arts\Ultima Online Enhanced

    You just rename the client file from "Ultima Online Enhanced" to something like "AbcUO" ( this should not effect playability )

    Then you can download a fresh copy of the client and install it without having to worry about it overwriting their client.
     
  15. MajinCry

    MajinCry Distinguished Member

    *Emerges from the darkness of Lurkdom* Oh my. Enhanced Client support? Why, I had given up all hope.

    'Tis what has been keeping me away from the ol' UO; the antiquated classic client is just too painful for the ol' eyes of mine.

    Anything in particular that needs tested? Or is the goal just to play as usual and see if anything burns?

    Edit: Think I found a lil' bug. The Disk Cache setting is @ 256MB by default. The slider, however, only goes from 1-20.

    2nd Edit: Found another. Overhead text and exclamation markers appear outside the render window. Lil' picture to demonstrate:
    [​IMG]

    3rd Edit: If you split a pile of coins, the initial pile disappears. To see it again, you have to refresh the screen (alt-tab/alt-enter)

    4th Edit: Dragged a pile of 400 coins to the instructor (with 200 left in the inventory). The 200 suddenly turned invisible, but then took the form of the candle's icon.

    Image to demonstrate:

    [​IMG]

    5th Edit: Dragging the candle icon caused the pile of money to appear, allowing me to place it elsewhere in the inventory bag. The candle icon now properly represents a candle, and I can see the pile o' coins. Seems that they shared the same tile after splitting the coin.

    6th Edit: When ascending stairs, you can see the feet of the running animation clip past the upcoming floor.

    Picture to demonstrate:

    [​IMG]

    7th Edit: A bit down the road from New Haven, the fort appears bugged; doors without adjacent walls and floating bookcases.

    Also, I do believe I picked Minoc as my starter town, not New Haven. Perhaps another bug?

    Image to demonstrate:

    [​IMG]

    8th Edit: Books are broken. It's the same two pages no matter what page number you're on. Also, you can be on the opposite side of a wall, and still open a book-case, as well as nab the contents inside. Also, the cobweb on the gate is called "Red Moongate". That ain't right.

    Image to demonstrate:

    [​IMG]

    9th Edit: The "Use Bandage On Self" skill is bugged; it's the exact same as "Use Bandage On Target" skill; the target cursor appears, and ya choose who to bandage.

    10th Edit: Moongates are invisible.

    Image to demonstrate:

    [​IMG]

    11th Edit: Lampposts have the wrong sprite; they show up as a flat wooden board.

    Image to demonstrate:

    [​IMG]

    12th Edit: Firepits are all messed up. Uses the incorrect sprite, and is in front of the cauldron rather than behind (under) it.

    Image to demonstrate:

    [​IMG]
     
    Last edited: Dec 26, 2015
    • Like Like x 1
  16. zerodowned

    zerodowned Administrator Moderator JustUO Developer Gold Star Member Et Cetera, Et Cetera

    MajinCry Thank you for reporting those :)
     
    • Like Like x 1
  17. MajinCry

    MajinCry Distinguished Member

    No worries man. I'd be far more active in the UO community if the EC Client was, well, usable for the shards out there. More than willing ta help get this thing going, if it means there'll finally be support for the new client.

    Found another bug.

    If you double click a bottle of ale, you'll be given the usual target-select cursor. Select yourself, the bottle of ale will not be emptied, though after a while, you'll eventually get the *hic* dialogue, even though your ale bottle is "full".

    Edit: Oh right, another bug.

    With the escortables, they do not have a run animation; they just have the plain walking animation.

    Another possible bug with escortables, is that they won't join you in combat. Back when I suffered through the Classic Client, back on UO Excelsior and UO Freedom, escortables would engage in combat with hostile NPCs. They don't do that on the test server.

    2nd Edit: The player's feet show through bookcases.

    Image to demonstrate:

    [​IMG]

    3rd Edit: The player-target-selection-ring clips through walls.

    Image to demonstrate:

    [​IMG]

    4th Edit:

    The player's feet clip through doors.

    Image to demonstrate:

    [​IMG]

    5th Edit: This lampost in Britain is using some odd half-clipped water trough sprite.

    Image to demonstrate:

    [​IMG]

    6th Edit: It seems that all hireables and escortables do not run, and instead move at the walking animation, which is then sped up when the running animation would instead play. They also stutter as the animation plays, which looks...Eww-ish.

    7th Edit: The number of pets displayed on the "Pets [0/5]" window doesn't update automatically whenever a follower/pet is obtained; it has to be 'refreshed' by clicking the arrow on the window, to display the current number of followers.

    8th Edit: At the Britain castle (fort?), the winch is hanging in midair.

    Image to demonstrate:

    [​IMG]

    9th Edit: The aforementioned fort is missing much of it's architecture.

    Image to demonstrate:

    [​IMG]

    10th Edit: Finally scrounged up enough coin to learn taming. Tamed a dog, and turns out pets have bugged movement as well. When far away enough, the first frame or two of the running animation will play, but then abruptly freeze. This repeats.

    So aye, I think it's safe to say that the running animations for followers is bugged.

    11th Edit: Using bandages on a hurt hireable (guard, peasant, etc.) doesn't work. The chat says "Bandages cannot be used on that".
     
    Last edited: Dec 26, 2015
  18. Zycron

    Zycron Illustrious Member JustUO Developer

    Ok so if you watch this video with the newest updated EC client and the new Launcher you posted it is still trying to connect to EA i "think". when i drop another serveres launcher into a IDENTICLE copy of the folder it loads right so i dunno if my OC doesnt like your launcher or if im just retarded but take a look!..

     
  19. MajinCry

    MajinCry Distinguished Member

    Probably a dumb question, but hey. If you click "LOGIN" instead of pressing enter, does it work?
     
  20. Zycron

    Zycron Illustrious Member JustUO Developer

    nope same error and when i put a different accoutn name in it is acting as if its still trying to connect to EA
     
  21. MajinCry

    MajinCry Distinguished Member

    Right-click uo-ec-loader.exe -> Properties -> Unblock.

    Still got the error?
     
  22. Zycron

    Zycron Illustrious Member JustUO Developer

    i dont have that option
     
  23. MajinCry

    MajinCry Distinguished Member

    Well, you're on Windows 10, which could be the cause of the problem. Right-click uo-ec-loader.exe -> Properties -> Compatability -> Windows 7. Do the same for UOSA.exe and UOSA_TC.exe.

    Still got the issue?

    Make sure there isn't some weird entry in your firewall that would block uo-ec-loader.exe or uosa.exe. If you have an antivirus running, try disabling it.
     
  24. Zycron

    Zycron Illustrious Member JustUO Developer

    Same problem. which is strange because like i said SAME install just different loader i can get on other private servers with it.
     
  25. MajinCry

    MajinCry Distinguished Member

    To clarify, your UOSA.exe version is 4.0.47.0, right?
     

Share This Page