Announcement New JustUo Test Shard up and running

Discussion in 'News and Announcements' started by zerodowned, Dec 21, 2015.

  1. Zycron

    Zycron Illustrious Member JustUO Developer

    indeed it is
     
  2. MajinCry

    MajinCry Distinguished Member

    Alas, I'm out of ideas.
     
  3. Zycron

    Zycron Illustrious Member JustUO Developer

    ill keep toying with it.
     
  4. MajinCry

    MajinCry Distinguished Member

    Seems that the sprites are having a hell of a time in deciding which NPC is drawn over the other. Couple of pictures showing the issue:

    [​IMG]
    [​IMG]

    1st Edit: Found another bug. If you expand the map, and try to resize it, it won't change size. You'll see the grey border, but it doesn't change in size.

    2nd Edit: When going to an NPC to change your hairstyle, the window is blank; there are no options to choose from.

    The feet of sprites go on top of the edge of a bridge...Not sure that's supposed to happen.

    Image to demonstrate:

    [​IMG]
     
    Last edited: Dec 26, 2015
  5. zerodowned

    zerodowned Administrator Moderator JustUO Developer Gold Star Member Et Cetera, Et Cetera

    For the sake of testing, I moved my existing ec client to a different folder and downloaded a fresh copy, patched fully, and then downloaded and dropped the loader from the original post.

    I had no connection issues at all.

    You said using the same install but a different loader you can sign into another private shard...
    Do you have different loaders in the same client file? They could be causing the issue.
    Are you using the client download from a private server's download or from uo.com?

    I noticed in the video that you used two different account names.
    Why?
    By default the accounts per IP is 1, so it won't let you create a second one.

    Please try this:
    Sign into the profile using classic client again to double check it's not an issue related to the account name and password you're using
     
  6. MajinCry

    MajinCry Distinguished Member

    Can't believe I didn't notice this until now. There's an animation glitch when using the bladed staff.

    During the running animation, the pole is held to the side of the player. As the player runs, it's brought forward and through the thigh, clipping with the player's sprite.

    Here's an image ta demonstrate.

    [​IMG]
     
  7. Zycron

    Zycron Illustrious Member JustUO Developer

    I am using a fresh client from uo.com different folders for other servers but same patched client just copied different copies of the folders. ill try removing everything and redowbloading again
     
  8. MajinCry

    MajinCry Distinguished Member

    Found another glitch. The wrong sprite is used for campfires made from kindling.

    Take a gander.

    [​IMG]

    1st Edit: When casting a spell, rather than play the casting animation, the walking animations is played.
     
    Last edited: Dec 26, 2015
  9. Zycron

    Zycron Illustrious Member JustUO Developer

    Fixed the problem ;P dunno how but it works now
     
  10. Nagash

    Nagash PlayUO Prospect

    You can also unblock cheese.dll and cheese.cfg. Another thing that might help (not sure why) is making an account with the 2d client and then trying to log on it with the enhanced client.
     
  11. MajinCry

    MajinCry Distinguished Member

    Found another bug.

    Typically, to rename a pet, you would double click it's name on target window, press backspace a few times and then type a new one in.

    Doesnae work for the EC; the target window doesnae respond to keyboard input.

    1st Edit: Beginning to think there are issues with the layers in which things are drawn. From the sprite bugs with multiple NPCs overlapping, to the issue with NPCs 'standing' on the railing of the wooden bridges.

    Here's another image demonstrating the bug; the item should be drawn underneath the chair (which is also bugged; has a cobweb on it for some reason) in New Haven Bank.

    [​IMG]

    And here's an issue showing clipping with character sprites and the walls of NH Bank.

    [​IMG]

    2nd Edit: When zoomed out, and a named character/NPC is in view, it initially has no name. When you get closer, the name dashes in from the left side of the screen. Looks pretty funky.

    Also, when a player character is unloaded after a while (30 secs?) by means of walking away until they are no longer rendered, but then rendered again, they'll play the walking animation.

    Another bug, is that horses and cows will occasionally play the dying animation as an idle.

    3rd Edit: One of my friends wanted to hop on with me and another of my buds (30 mins ago), but when trying to make a new account, he got that network error stuff. My current bud and I, that can login fine with our current accounts, tried making new ones.

    We too got that network error when trying to create new accounts.

    Also, I think those teleporters in Jelom are bugged. Stepped on one on the main island, got sent to a small island; can't leave the small island the same way.
     
    Last edited: Dec 27, 2015
  12. Zycron

    Zycron Illustrious Member JustUO Developer

    Inventory Bug when i loot shepards crook or certain peices of bone armor they dont show in the inventory of EC but when u log over to old client everything is in inventory
     
  13. MajinCry

    MajinCry Distinguished Member

    When a player is no longer being rendered, and is then rendered again, he may appear completely naked, and without a mount. It may go away when the above is repeated; the other player is no longer rendered, and is rendered again.

    [​IMG]

    1st Edit: Fire Wall is bugged out; it shows a messed up sprite of green vines.

    2nd Edit: When you drop a candle, it's sprite is that of a stool.

    3rd Edit: Now, this isn't much of a bug, but all of your followers will follow you, all staying on the same tile. That looks really, really bad. This has been the case since the CC, and is the case with the official UO servers (right?), but it still looks awful.

    Any chance of getting that fixed, so they follow on adjacent tiles? It just looks bad with them overlapping.

    4th Edit: The "Equip Weapon" skill-things are bugged. They don't do anything; no weapon equipped, use "Equip Best Weapon", nothing happens.
     
    Last edited: Dec 27, 2015
  14. MajinCry

    MajinCry Distinguished Member

    Out of curiosity, has there been any progress on converting maps to the new .uop format used by the EC? I do remember trying to get custom maps working using the various .mul to .uop converters, but the .uop format has changed over time.
     
  15. MajinCry

    MajinCry Distinguished Member

    Uh, dunno if we're allowed ta multi-post, but I figure it's alrighty, seeing as how there's a change in subject.


    Found another bug: Casting "Reactive Armour", whilst mounted, will cause the spell to play as normal, but no buff will be given. Turns out that Reactive Armour, when it fails, doesn't notify you of that fact; it plays as if it succeeded.


    1st Edit: There is no Pet Info option in the pet context menu, making it impossible to properly level our pets.

    2nd Edit: Boats are rather horribly bugged. When they move, only a couple parts of the ship moves. The rest of the ship appears only after stopping all movement of the ship, then turning it.

     
    Last edited: Dec 29, 2015
  16. MajinCry

    MajinCry Distinguished Member

    Quadruple post, eh?

    Seems that the ol' test server has been down for the past 12 hours or so. Something happen, or is this lil' testing period over?
     
  17. HawkEye

    HawkEye Super Contributor

    Yeah boats are bugged with ec but in cc there not.. If we had the HS ship package in boats would work because the hs ship package calls the new boat packet that ec reads.

    Buffs and all that are not a ec problem there more or less a code problem being there not up to date to give the correct buff info..
     
  18. HawkEye

    HawkEye Super Contributor

    also noticed most of your bugs you have posted about bad graphics in ec, example the camping kindling seems to look normal to me in the ec and I haven't seen any naked people lol. you sure you have a fresh install ec client just checking.
     
  19. MajinCry

    MajinCry Distinguished Member

    Aye, fresh install that's been fully patched. The bugs I've reported were also experienced by my bud that I was playing with.

    You made sure to ignite the kindling, and not just drop it, aye?

    And the players/mercs nude bug doesn't always occur. You may need to constantly un-load (by walking a fair amount until the player/merc is no longer rendered) and reload the player/merc to experience it. If you play with another player for a wee while, you'll encounter it soon enough.
     
  20. HawkEye

    HawkEye Super Contributor

    aw might be a refresh problem in ec ill have to check that but the items and casting spells all that seem to work right..

    the clipping of the mobile in the buildings that a ec client but I reported it to broadsword as I play there servers.

    but I tested with JustUO and ec together and I cant seem to get the kindling or spell bugs you come across to happen. ill keep looking into it. so don't take my post as I don't believe you I do. and its great to see you testing it..

    also I just noticed zerodowned has posted a link to ec tools for map making ect you might want to check those out.

    I'm looking now at the refresh in ec.. Boat bugs well soon as what his name finishes his hs package it would get added to JustUO as well so that should fix all the boats
     
    • Like Like x 1
  21. MajinCry

    MajinCry Distinguished Member

    Does the "Fire Wall" magery spell have the proper graphics for you? For my bud and I, it had the graphics of tall ivy...Which was fairly disappointing. We wanted burnination, dangnammit.

    Bloody hell, the clipping sprites is an issue with the official shards? You'd think their Q/A team would have noticed that.

    Oh, I ain't taking this personally, don't worry; 'tis the nature of bugs. Some people get them, others don't.

    And aye, I just happened upon the EC tools he posted. Quickly downloaded those bad boys. Gotta start brushing up on World Machine.
     
  22. Kyn

    Kyn Distinguished Member JustUO Developer

    Hey, I've been experimenting with the EC for a little bit and I'm just curious if there is any way to edit the gump art in the client. I know that UO Fiddler was a great tool for the regular client but obviously it cannot modify/edit UOP files :(

    Any suggestions? I'm hoping to modify/adjust the clients opening gump artwork.
     
  23. HawkEye

    HawkEye Super Contributor

    I'm in JustUO test center and the ec client is running smooth for me. also I'm running latest ec client on windows 10

    okay I noticed the camping bad graphics and the firewall bad graphics on tc.. that is werid



    zerodowned did something change from all the files I sent u?
     
  24. MajinCry

    MajinCry Distinguished Member

    Try givin' this a shot?

    http://www.playuo.org/emu/index.php?threads/ec-client-tools.1347/
     
  25. Kyn

    Kyn Distinguished Member JustUO Developer

Share This Page